Showing results for 
Show  only  | Search instead for 
Did you mean: 

Problem with UAS at first access

Super Contributor



As we use Hopex V2R1 which is out of support, I need your help.


We've just activate the UAS component (for SSO) and it works when someone is already using Hopex, but at the first access (first in the morning, or when no use during around 30min, ...) an error is always displayed :


and we need to refresh (F5 or CTRL+F5) to get the login screen :



It looks like Hopex has problem to "wake up".


I checked the logs and I found :

 - in uas log :

2021-12-07 17:32:54,081 [1] DEBUG /LM/W3SVC/1/ROOT/UAS-1-132833681719450900 - Mega.UAS.Web.Startup -  SSP : "HTTPS://xxx/MegaSSP"
2021-12-07 17:32:54,346 [17] ERROR /LM/W3SVC/1/ROOT/UAS-1-132833681719450900 - System.Threading.Tasks.TaskCanceledException - A task was canceled.


 - in sspsprvs log :

17:32:54 xxx WebserviceFactoryError 0 0 859 74362880 74362880 0 0 71 0 5616 - 2021/12/07 17:32:54 F A UAS Exception


As this errors occurs each time where nobody uses Hopex during some time, it's impossible to use UAS in Production for our users.


Anybody has an idea about this problem ?




5 Replies


I am trying to set up SSO using SAML and having one issue, wish you could help with

In the SAML configs I defined SAML issuer to be https://servername/UAS and return URL to be https://servername/hopex

In MEGA meta data placed in the IdP side, I mentioned the same as issuer and Acs. As far as I understand the information in SAML request and meta data should be matched so that IdP could accept it.

The issue is that SAML request has different information, the Acs is https://servername/UAS/AuthServices/Acs and I am not sure from where this is coming it's not mentioned anywhere.

Kindly look at the attached SAML config, MEGA metadata, and decoded SAML request.


Super Contributor

Finally, I found the cause : the URI of the metadata XML file.

We used an URL and we change to a local path (C:\...). That solved the problem.

I have seen this behaviour, it shows error first time and works fine afterwards if the page is refreshed. It was found that addresses were not correct, in the Megaside.ini file under the [Authentication] TAG.
It will be a good idea to double check the tags in Megasite.ini related to SSO authentication/settings.

Super Contributor


1. We use SAML2.

2. All web.config are correct. The UAS and the SSO authentification work well when Hopex is awake (in use by some users). The problem is only when Hopex is not used for few dozen minutes and its processes are standby.

3. We don't use loadbalancer



MEGA Partner
MEGA Partner




1. What kind of authentication are you using i.e. SAML2, Windows IIS, Google etc?


2. You need to check if the addresses in megasite.ini are matching with all the config files (web.config) in all folders under wwwroot, especially in these folders:






Example: Megasite.ini



3. If you are using a loadbalancer in front of two+ web servers then the loadbalancer address should be mentioned in megasite.ini instead of the actual server's address (in this case ignore point 2).




Important: make copies of the config files before changing them, so you can restore them if anything goes wrong.


I hope this will help.