Showing results for 
Show  only  | Search instead for 
Did you mean: 

Unable to patch...

MEGA Partner
MEGA Partner

Hi community.

We did CP update, we followed the manual and it looks everything is going good, but at the end, when we try to do the "Environment automatic update", we received a message:

"Unable to patch a repository with existing transanctions, publishing or delete all transanctions first then restart."

We followed the recommendationm execute "remove not referenced repositories" and nothing helps. 

Also the recommendation of delete pending transactions in every workspace, but nothing seems to work.

What could be the solution of it? 



Thanks for your help. 

11 Replies




As previously mentioned by my colleagues the problem was related to a workspace, so after deleted the problem will be solved.


Kind regards, 





As mentioned by jcamara the workspace that you see for "Unknown User" is the source of the error:  "Unable to patch a repository with existing transactions, publishing or delete all transactions first then restart."


When the documentation states that you must dispatch/discard all transactions prior to upgrade it is including the System Repository in that statement. 


Please let us know if this resolves the issue for you and if you have any further questions. 






The "Unknown User" workspace in the System Repository is the one that is blocking you. Try deleting it and you should be able to then continue with the CP upgrade described in our online documentation.


I hope that helps.

I'm attaching the image to show the checkbox I'm talking. 

If select the same checkbox in the other repositories, no one shows nothing, only sysDB does. 

You can see 2 "users", the green one match with the session Im using now. 

If I selected the same checkbox in the other repositories, no one shows any user in there, only sysDB.




Can you elaborate on "it shows me some process, but only if i select that checkbox"?

There should be nothing showing in the Workspace window with the checkbox checked or unchecked.

If you see workspaces when you select the checkbox then this is part of the problem and they need to be removed. 



I did, i logged with the "System" account, the main and default account to log into Adminitration.exe., I opened the workspace of it and its empty, every workspace its empty, if i click on the checkbox "system repositoy" it shows me some process, but only if i select that checkbox, also, we check the folder sysdb.transactions, and there are a lot of BAK files, you think that coulb be part of the problem? the amount of BAK files in that folder? 




You have to log into the environment with the "System" account to manage the workspaces (at this point you would have to delete them since you have already patched the software and would be unable to log into the environment.


Again, please be sure you have a backup of the environment at the original version in case you encounter issues.


I hope that helped.

We did the "perform SQL..."  and not helping. It appears the same message if we try to update the environment.




The message is referring to existing Workspaces of the repository/repositories. These are typically managed via Administration.exe by right-clicking on Workspaces>>Manage at the version the environment was currently at.





Since you have seemingly applied a patch, and assuming you performed a backup of the environment at the original Hopex version, you could attempt to execute the above at the patched version before you can progress with the full Automatic update to progress with the upgrade.


You may find you have to execute "Perform Sql Conversion" if you find you are unable to manage the repository (Red X on the Repository reference)





the version is HOPEX_V4.00.04, and yes all the services were totally stopped,