Showing results for 
Show  only  | Search instead for 
Did you mean: 

Inserted Image using Shape Editor is not Visible

Trusted Contributor

Hello All,

I created a new MGS File by inserting an image using the Shape Editor and saved it in the folder : C:\Program Files (x86)\MEGA\HOPEX V4\Mega_Std\pictures.7600\method


I also copied the inserted image to MEGA_usr folder as suggested in the following threads:



But I can still see a white box where I inserted and image and saved the MGS File.



Why could this be happening?
I also tried by importing WMF file instead of PNG but it is not working either.

7 Replies

I contacted MEGA Support and the following solution received from them worked for me:

Instead of inserting an external image using the 'Insert' option in Shape editor, take a screenshot (by using snipping tool) to capture the external image you want to import. Copy the image from the snipping tool and paste (Ctrl+V) it directly onto the Shape editor screen. Save the image as MGS file using 'Save As' to Mega_usr folder.

I am not sure I understand. I also tried with WMF and got the same result.

Could you please elaborate? How should I go about this, when the client wants to add a new Shape for IT Device?

The main difference is that you are replacing a vectorial object by a PNG. Not sure it behave as you expect.


Steps Followed: (screenshots attached)

1. I took a backup of an existing MGS file and opened the file in Shape Editor. Removed the image I wanted to replace with the new image.

2. Insert -> Shape

3. Selected the .png file I wanted to insert. (The same steps were done earlier for a .WMF file)

4. The image was inserted.

5. Using "Save As", saved the file with new name in the path : C:\Program Files (x86)\MEGA\HOPEX V4\Mega_Std\pictures.7600\method


-> The .png file is present in the Mega_usr folder


Issue in Windows Front-End: On opening the mgs file I just saved on Shape Editor, the inserted image is missing.




Issue on Web: The new Shape is present in the Hopex Web Client and I can see the shape after adding it in the diagram. But the displayed icon contains the empty white box.




Share some screenshot Of the step you follow. Otherwise it will be difficult to help you.

Hi, I referred to the post which mentioned saving the image to the Mega_std folder.

I am unable to share the MGS file via upload option in the community.




First you should never put any custom file here : C:\Program Files (x86)\MEGA\HOPEX V4\Mega_Std\pictures.7600\method


but in the Mega_Usr folder as suggested.


Could you share your MGS file ? Maybe what you do is not allowed ?


What could happens as well is that there is a script to positionned the shape. This script probably resize your image and you don't see it anymore