Showing results for 
Show  only  | Search instead for 
Did you mean: 

HTTP 413.1 error: Request Entity too large

Super Contributor


I am facing an http error 413.1, with Hopex V5, when I tried to download a new module from a file.

Have you ever had such a problem, and a possible solution.


Thanks in advance.

4 Replies



it seems that you have an issue with IIS configuration.


Did you reuse an existing IIS ?

Maybe you have some default IIS policy applied ?





I have found a solution to this problem, which occurs when I use Url redirection.
If I access my instance from the HAS console using the address as https://Server_Name:Port_Number, then in this case I'm able to upload the add-ons I need.

Has this kind of behaviour ever been reported?



Super Contributor

I have installed HOPEX in its V5 CP4 HF8 version, on a Windows 2016 Server + SQL Server 2019 infrastructure, following the installation guide.
From the HAS console, I created a new instance.
Following this first phase, I want to add the 'Environment Installation Package' (449 MB) and 'Environment migration Package' (707 MB).

As I don't have internet access from the server, I have downloaded these packages to the local disk of the server.
I want to add the first module from the HAS console, by Add new module, by doing an Upload from file.

The upload starts and I get an http 413.1 error almost immediately.

I tested the manipulation, both with an https configuration, and in http: same error in both cases.

A search on the internet indicates that it can be necessary to modify an IIS setting: modification of uploadReadAheadSize to 2147483647, the maximum value: I made this modification but it does not generate any change.

Do you have any idea what could be causing this problem? Or is there another way to add module ?



Can you share more details of what you are trying to do ?


Module size is limited to 2Gb.