cancel
Showing results for 
Search instead for 
Did you mean: 

(Solved) Rollback during installation - Hopex V2R1

Highlighted
MEGA Partner

(Solved) Rollback during installation - Hopex V2R1

Hi, all!

Recently, I faced an issue during installation process of Hopex V2R1 in a customer.

 

Issue:

The installation was based in a horizontal deployment, having 3 APP servers under a load balancer (bigIP) and an exclusive server for SSP.

Follow below the configuration of servers:

Windows Server 2016 Standard

IIS 10

.Net 4.7

SQL Server 2016

 

So, in the end of installation process when it was going to create the Virtual Directories of Hopex, the installation was aborted and rollback whit the follow error message on log:

   "InstallShield 00:54:09: AddElement failed with the following HRESULT: '-2147024863':
InstallShield 00:54:09: Error with IISRT: -2147024863. Error translation: The process cannot access the file because another process has locked a portion of the file.
CustomAction ISIISInstall returned actual error code 1603 (note this may not be 100% accurate if translation happened inside sandbox)
Action ended 00:54:09: InstallFinalize. Return value 3.
Action 00:54:09: Rollback. Rolling back action"

 

Resolution:

IIS 7 and newer versions comes with some sessions locked, that can result in problems like this one, resulting in rollback of installation.

So, to resolve it, follwo these steps bellow:

- On IIS, expand and select the website wher Hopex is installed.

- Click on "Configuration Editor"

- On "Session", expand "system.webServer" and select the defaultDocument.

- Click on "Unlock Session".

After that, the installation concluded with success.