cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Import Issues - There is no 'Generality' for 'Absolute Identifier' that has the 'ZZZZZZ' value

Solved
Highlighted
Occasional Contributor

Import Issues - There is no 'Generality' for 'Absolute Identifier' that has the 'ZZZZZZ' value

I'm having issues importing a set of Overview of Applications daigrams.  The errors are all of the type - "There is no 'Generality' for 'Absolute Identifier' that has the 'ZZZZZZ' value".  A report file is attached - tis is really an MGR file.  When I look under the MainObjects tab, I see the Generalities listed there (see attached picture).  I'm not sure what is going on.  I've been quite successful with other exports and imports today.  Thanks.

 

John

5 Replies
MEGA

Re: Import Issues - There is no 'Generality' for 'Absolute Identifier' that has the 'ZZZZZZ' value

Hello John,

 

it seems to me, but I might be wrong, that you are exporting objects from the "Development" repository, into the "WIP" repository. The error message means that the concerned Generalities ("MB TPA Manual", "QBENA"...) do not exist in the target repository (WIP). Maybe do you have Generalities with the same name but different absolute identifier in your source and target repository ?

Since your diagrams  seems to have had no problems at import, you should either connect manually your diagrams to your generalities, or export your generalities (without propagation) from your source to your target repository, and then re-import your reject file.

 

Regards,

 

Lionel

 

Occasional Contributor

Re: Import Issues - There is no 'Generality' for 'Absolute Identifier' that has the 'ZZZZZZ' value

Lionel,

 

I tried exporting the generalities yesterday, but had the same problem.  What do you mean 'without propagation'?  How do I do that?  Thanks.

 

John

Occasional Contributor

Re: Import Issues - There is no 'Generality' for 'Absolute Identifier' that has the 'ZZZZZZ' value

Lionel,

 

I figured out what you mean by 'without propagation' and was able to try that.  The first time I imported it, It didn't appear to add the Generalities to MEGA.  I discarded that attempt and tried again.  The second time, I could see the generalities appear as the file was imported.  However, when I did a save and Dispatch, the generalities went away.  I went ahead and tried to import the Overview of Applications diagrams and had the same errors.  I discarded that attemp and tried a third time.  On the third attempt I imported the generalities and they appeared.  I immediately begin importing the diagrams.  They imported without error.  I saved and dispatched and all seems to be OK.  Now on to solve the other issues in the other message.  Thanks.

 

John

MEGA

Re: Import Issues - There is no 'Generality' for 'Absolute Identifier' that has the 'ZZZZZZ' value

That seems really strange... are you working in two different environments ? because Generalities are System objects and should be seen in all the repositories of one same environment.

But the fact that you had to import 3 times to have it work... I simply do not understand. But if it works... :-)

Occasional Contributor

Re: Import Issues - There is no 'Generality' for 'Absolute Identifier' that has the 'ZZZZZZ' value

Lionel,

 

They are two different environments.