cancel
Showing results for 
Search instead for 
Did you mean: 

Error running a report after upgrading from V2CP5 to V2R1U3

Frequent Contributor

Error running a report after upgrading from V2CP5 to V2R1U3

Hi,

 

we have a custom java report that looks for a Project object as input. After upgrading from V2CP5 to V2R1U3, the report isn't working anymore. The code hasn't changed, but we are now getting an error like the one below:

 

Analysis generation failed:
Error : MEGA Error 0x80020009(Object Add Error) : ~qekPESs3iG30{MetaClass}[EA Project] 'EIT_2018_MEGA HOPEX 3_2' object: Already belongs to the collection

 

We also get a similar error on a report that takes a query as input. Again - our code hasn't changed between V2CP5 and V2R1U3...

Anyone have any ideas what may be causing this?

Thanks!

Philippe

2 REPLIES

Re: Error running a report after upgrading from V2CP5 to V2R1U3

One of the conversion utilities converts EA project objects into regular Project objects - perhaps you ran that and dont have any more EA projects?

Frequent Contributor

Re: Error running a report after upgrading from V2CP5 to V2R1U3

Hi David,

 

We ran the upgrade in another environment, without running the EA Prroject utility, and are still facing the same issue. We're also seeing this issue on a custom report that takes queries as parameters. I've submitted a ticket to support in the meantime.

 

Thanks!

Philippe