cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Error message in report - What to look for?

Contributor

Error message in report - What to look for?

Hi,

 

I created a few reports in Mega. When I first click on them after opening the thick client, or right after a dispatch, I get error "The value (Long number) of Comment (English) attribute cannot be found on the object Report Parameters. (see attached image).

 

If I click on a different report then click back on the report with the message, the error go away.

 

I have this on several reports on the first time I click on them. I have checked all comments related to the report, but not luck yet...

 

Any idea of where I could look for in order to get this resolved? Can I get more details on this error (logs?) somewhere to debug this?

 

Thanks

 

Simon

6 Replies
MEGA

Re: Error message in report - What to look for?

Hello Simon

 

It is likely that this report is not consistent.

You can run a check in Window Front-End

See http://community.mega.com/t5/custom/page/page-id/mega-kb-solution?sid=501D00000014UscIAE

 

Jerome
Contributor

Re: Error message in report - What to look for?

Hi,

 

The result I get is "This rule is verified" for all conditions. So it's not the problem. I still get the same message and in the "reports" tab, I get Error: The report cannot be run.

 

Then I select a different report and re-select the first report: it runs fine. 

 

Weird...

Contributor

Re: Error message in report - What to look for?

Hi,

 

I think I found what is causing the error, but I think I'll have to open a support case for this.

 

There is an object called "Report Parameters" of type "Report Chapter" (see image attached in Word file). 

 

As soon as this object is opened to view its properties, I get the same error message as I have in all my reports: "The value  (6457692212826566082) of Comment (English) attribute cannot be found on the object Report Parameters."

 

If I log in French, I have the same message except I get the Comment (French) part. 

 

I tried to enter a comment in the "comment" tab of the object. I saved and nothing happens, when I close and re-open the property windows, the comment is gone. 

 

I tried assigning the comment using Scripting that way: 

 

'MegaContext(Fields,Types)
'Uses(Components)
Dim myObj as MegaObject

set oRoot = GetRoot

set myObj = getobjectfromID("rNzHxVqE6P10")

myObj.GetProp("Comment (English)") = "My Comment"

print myObj.GetProp("Comment (English)","Display")

 

When I do so, I get error: 

Script Editor Default : Property Update Error line 6, offset 1 :
Error(0x800ac012) : Object ~EJiRKC8A6Lf0{MetaClass}[Report Chapter] , Property Comment (English)Smiley Surprisedccurrence deprecated version

 

So, it looks like a Mega bug where this comment is needed for report, but cannot be entered.

 

Any help?

Contributor

Re: Error message in report - What to look for?

Hi, 

 

For your information, I opened case 00040697 for this.

 

Simon

Contributor

Re: Error message in report - What to look for?

Hi,

 

I am with Hopex CP4 and I don't have that problem when I open the Report Parameters properties.

 

Have you tried to translate and compile the environment? Or see if there has been someone making changes to the object?

Contributor

Re: Error message in report - What to look for?

Hi,

 

Yes the environment was translated and compiled many times, but I think that compiling including permissions fixed a couple of odd behaviors I had.

 

I sent a video to technical support to display how to reproduce the problem linked with the case opened. The problem occurs after dispatch. Looks like the dispatch resets something in the environment variables. 

 

The objects are not locked, nobody changed them... Since not many users changes information and dispatch, not many will actually see the error. So, I will live like this until I get news from the technical support.