cancel
Showing results for 
Search instead for 
Did you mean: 

Disappearing associations on class diagrams

Occasional Contributor

Disappearing associations on class diagrams

Some of our mega-users have the same complaint : sometimes some associations are no more visible on the diagram without any reason. Although the associations do still exist, they are not shown anymore.

Up to now I am unable to simulate this problem. In the log files i can't find any disconnect.

In all cases the problem concerns associations on class diagrams. Does someone else have the same complaint?

 

Thanks

Jan Cortoos

1 Reply
MEGA

Re: Disappearing associations on class diagrams

Hello Jan

 

We are not aware of this behavior (sometimes associations are no more visible on the diagram without any reason).

 

Possible causes:

  • The association has been deleted in the repository by another user.
  • The association has been explicitely removed from the diagram by another user.
  • One of the class objects connected to association is removed from the diagram and, as a consequence, the association is removed from the diagram.
  • One of the class objects connected to association is deleted from the repository, cascade deletion of the association is confirmed and, as a consequence, the association is removed from the repository and the diagram.

It you have a more specific scenario, please open a case in support with the following form.

http://community.mega.com/t5/custom/page/page-id/mega-support-case

 

Jerome