cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Compilation error after CP

Solved
Contributor

Compilation error after CP

Hi,

 

I'm currently upgrading Mega DEV environment from V1R3 CP13 to V1R3 CP17, as part of the migration to V3.

I applied first CP14 and run metamodel compilation successfully.

I applied then CP15, but when running metamodel compilation, it didn’t go through and stopped half way with this error message in MegaCRD file :

 

----------------------------------------------------------

 Compilation error or warning when processing [MetaClass]_Alert (45D14729523C15BF)
There is no 'MetaAttribute' for 'Absolute Identifier' that has the 'n300000005B0' value. - gbmoccse.cpp(562) 0x100845E
Compilation error or warning when processing [MetaClass]_Class (0CA90D092BFA0017)
There is no 'MetaAttribute' for 'Absolute Identifier' that has the 'n300000005B0' value. - gbmoccse.cpp(562) 0x100845E
Compilation error or warning when processing [MetaClass]_ClassCommand (0CA90D0A2BFA001F)
There is no 'MetaAttribute' for 'Absolute Identifier' that has the 'n300000005B0' value. - gb

......

---------------------------------------------------------------------------------------------------------------

 

..... and the list goes on for almost all metamodel objects.

No meta object is available in PRD environment with this Abs Id.

Can you please help?

 

Mehdi

6 Replies
MEGA

Re: Compilation error after CP

Hello

 

It is likely that certain upgrades have not been made and that metamodel elements are missing.

See https://community.mega.com/t5/custom/page/page-id/mega-kb-solution?sid=50157000001KX4wAAG

Jerome
Highlighted
Contributor

Re: Compilation error after CP

Hi Jerome,

 

Thank you for your quick reply.

 

Can you please confirm that I only need to import "UpgradeR3.mol" and it will take care of importing the other .mol files? Or do I need to import manually all of them with the order you showed ?

 

Mehdi

MEGA

Re: Compilation error after CP

Manually re-import UpgradeR3.mol only and restart the environment upgrade
-> this should restart automatically the import of the other MOL files
Otherwise you need to import them manually in the expected order
Jerome
Contributor

Re: Compilation error after CP

Hi Jerome,

 

I'm confused with the version available for download on this link :

 

https://community.mega.com/t5/Download-Center/HOPEX-V1R2-V1R3-Download-amp-Updates/ta-p/8313

 

It says "Download V1R3 CP17 Master", but I get the version V1R2 CP17. Same for the CPs down the page, all for V2.

 is it the root cause of the errors I got during the compilation?

Thanks

Mehdi

MEGA

Re: Compilation error after CP

Hello

 

What is the exact version display in Help > About HOPEX?

Jerome
Contributor

Re: Compilation error after CP

Hi,

 

Current version displayed on my DEV server: Mega Hopex V1R3 (750 - 4936).

So the master file available online is correct.

 

When I link the environment to this new version, no message pops up requesting conversion, metamodel compilation goes well, and SysDb > Conversions menu is greyed out.

 

I'll go ahead and open a new topic to discuss this specific issue.

 

Thank you very much for you help

 

Mehdi