cancel
Showing results for 
Search instead for 
Did you mean: 

API - Can't even login ?

Highlighted
Contributor

API - Can't even login ?

Hello, 

 

We are trying to test the API features to generate reports.

However, it seems we can't even pass the login phase...

 

All is configured according to the exemple, but looking at the logs we saw that :

2019-08-21 16:27:20,449 [64] INFO  /LM/W3SVC/1/ROOT/UAS-1-132108916563800795 - System.Reflection.RuntimeAssembly - Start token request
2019-08-21 16:27:20,449 [64] INFO  /LM/W3SVC/1/ROOT/UAS-1-132108916563800795 - System.Reflection.RuntimeAssembly - Start client validation
2019-08-21 16:27:20,449 [64] INFO  /LM/W3SVC/1/ROOT/UAS-1-132108916563800795 - System.Reflection.RuntimeAssembly - Start parsing Basic Authentication secret
2019-08-21 16:27:20,449 [64] INFO  /LM/W3SVC/1/ROOT/UAS-1-132108916563800795 - System.Reflection.RuntimeAssembly - Start parsing for secret in post body
2019-08-21 16:27:20,449 [64] INFO  /LM/W3SVC/1/ROOT/UAS-1-132108916563800795 - System.Reflection.RuntimeAssembly - No secret in post body found
2019-08-21 16:27:20,449 [64] INFO  /LM/W3SVC/1/ROOT/UAS-1-132108916563800795 - System.Reflection.RuntimeAssembly - Start parsing for X.509 certificate
2019-08-21 16:27:20,449 [64] INFO  /LM/W3SVC/1/ROOT/UAS-1-132108916563800795 - System.Reflection.RuntimeAssembly - client_id is not found in post body
2019-08-21 16:27:20,449 [64] INFO  /LM/W3SVC/1/ROOT/UAS-1-132108916563800795 - System.Reflection.RuntimeAssembly - Parser found no secret
2019-08-21 16:27:20,449 [64] INFO  /LM/W3SVC/1/ROOT/UAS-1-132108916563800795 - System.Reflection.RuntimeAssembly - No client secret found
2019-08-21 16:27:20,449 [64] INFO  /LM/W3SVC/1/ROOT/UAS-1-132108916563800795 - System.Reflection.RuntimeAssembly - End token request
2019-08-21 16:27:20,449 [64] INFO  /LM/W3SVC/1/ROOT/UAS-1-132108916563800795 - System.Reflection.RuntimeAssembly - Returning error: invalid_client

No secret in post body ?

No client_id in post body??

 

Config in wwwroot\UAS\config.json

      "HopexAPI": {
        "Enabled": 1,
        "Flow": 4,
        "ClientId": "HopexAPI",
        "Scopes": "read;write;offline_access;openid",
        "ClientSecret": "secret",
        "ClientName": "Hopex WebServices"

Result and poke with PostMan

image.png

 

 

Any idea ?

 

Thanks a lot, 

Raphaël. 

Tags (1)