cancel
Showing results for 
Search instead for 
Did you mean: 

Index descriptor empty when menu is enabled

SOLVED
Contributor

Index descriptor empty when menu is enabled

When generating a website with "With menu" option enabled, generated index pages are empty (content is "<html></html>").

 

In order to generate actual content, "With menu" option has to be disabled at the page or website level.

 

Given this behavior, is it possible to insert website menu into specifc index pages?

 

 

Note:

Impacted descriptors are created in the HTML Web Site Specific Page / Specific Html <Body> in folder.

Automatic indexes such as Alphabetical Index are not impacted.

 

 

Sergueï

8 REPLIES
Contributor

Re: Index descriptor empty when menu is enabled

Moreover, following error is reported in MEGA 2009 SP5 CP5 and CP6.

 

When generating an index page with "With menu" option enabled, and using a StringFunction tag such as:

<h1>[StringFunction=GetLeft Length=5]Hello world![/StringFunction]</h1>

 

Then generation fails with following trace:

Thread(0868);rpobjdoc.cpp(2806) : error trace 11:19:13
Thread(0868);rpobjdoc.cpp(2740) : error trace 11:19:13
Thread(0868);rpobjdoc.cpp(3729) : error trace 11:19:13
Thread(0868);htmprovb.cpp(1959) : error trace 11:19:13

Thread(0868);solv_stf.cpp(149) : error Application: 0x01008001 11:19:13
The application has encountered an error. If this problem persists contact tec
hnical support.
Thread(0868);solv_stf.cpp(1534) : error trace 11:19:13
Thread(0868);dostag.cpp(1236) : error trace 11:19:13
Thread(0868);dostag.cpp(1440) : error trace 11:19:13
Thread(0868);dostag.cpp(1184) : error trace 11:19:13
Thread(0868);dostag.cpp(1440) : error trace 11:19:13
Thread(0868);tagparse.cpp(199) : error trace 11:19:13
Thread(0868);htmstd.cpp(749) : error trace 11:19:13
Thread(0868);htmstd.cpp(769) : error trace 11:19:13
Thread(0868);dntext.cpp(272) : error trace 11:19:13
Thread(0868);dnroot.cpp(149) : error trace 11:19:13
Thread(0868);dosobj.cpp(2642) : error trace 11:19:13
Thread(0868);dosobj.cpp(2798) : error trace 11:19:13
Thread(0868);rpobjdoc.cpp(2917) : error trace 11:19:13
Thread(0868);rpobjdoc.cpp(2778) : error trace 11:19:13
Thread(0868);rpobjdoc.cpp(3865) : error trace 11:19:13
Thread(0868);htmprovb.cpp(2023) : error trace 11:19:13
Thread(0868);htmprovb.cpp(2029) : error trace 11:19:13
Thread(0868);dosobj.cpp(2802) : error trace 11:19:13
Thread(0868);dosobj.cpp(3436) : error trace 11:19:13
Thread(0868);hdosfmto.cpp(1122) : error trace 11:19:13
Thread(0868);sitecontentdef.cpp(682) : error trace 11:19:13
Thread(0868);sitecontentdef.cpp(729) : error trace 11:19:13
Thread(0868);webgeneratorobj.cpp(1993) : error trace 11:19:13
Thread(0868);webgeneratorobj.cpp(3634) : error trace 11:19:13

MEGA

Re: Index descriptor empty when menu is enabled

Hello Sergueï,

 

it clearly seems to be a bug (you should email to support@mega.com :-)

(I tried on my computer and have the same problem as you)

If I were you, I would choose "Complete page" for the "HTML page generation format" option of you specific descriptor.

You will then have to write the code for your menu inside your descriptor, which is more work, but at least it works :-)

 

Lionel

<script id="F5_watermark" type="text/javascript"></script>

<script id="F5_watermark" type="text/javascript"></script> <script type="text/javascript">// try{F5_flush(document);}catch(e){} // </script> <script id="F5_watermark" type="text/javascript"></script>
Contributor

Re: Index descriptor empty when menu is enabled

Thank you Lionel for your advice!

 

Manual menu creation is however complicated because of the wide variety of parameters (top/left menu, frames...).

 

I will report this issue to MEGA Support and update this topic.

 

Sergueï

MEGA

Re: Index descriptor empty when menu is enabled

Hi smilechine,

 

Could you please provide me with further elements to better understand and analyze this issue?

 

I will need  the export with propagation of the involved website + the used MTH file + the CSS file

 

Thanks

 

Contributor

Re: Index descriptor empty when menu is enabled

Hi Mohamed,

 

These are the steps I went through, to build the website:

- Create an Application "Application-1"

- Create a website with no template (Default)

- Add Application-1 as object, and disable Propagation

- Add EA_Application page

- Add EA_Applications_List_Index index page

- Generate (with errors)

 

The corresponding MGL logfile is attached to this message.

 

Sergueï

MEGA

Re: Index descriptor empty when menu is enabled

Hi,

 

Ok, i could reproduce the same issue with the provided elements, i created a case about this issue to be analyzed internally by the R&D team.

 

I will keep you informed once i get a feedback / solution for this problem

 

Thanks

MEGA

Re: Index descriptor empty when menu is enabled

Hi,

 

This issue is now followed by the CR 30606 . I will keep you informed once i get a feedback / solution for this problem.

 

Thanks

Highlighted
Contributor

Re: Index descriptor empty when menu is enabled

Thank you Mohamed!

 

Let me know if you need any additional information.

 

Sergueï